Upgrading to Go 1.4

by Kasper Tidemann

If you’ve just upgraded to the newly released Go version 1.4, chances are you may be getting errors like these:

# command-line-arguments
./app.go:7: import /Users/kasper/Go/pkg/darwin_amd64/lib/env.a: object is [darwin amd64 go1.3.3 X:precisestack] expected [darwin amd64 go1.4 X:precisestack]

This is caused by previous compilations of the code. To fix the problem, just delete your $GOLANG/pkg folder and you should be good to go again.